We are currently planning to migrate to a different platform for the forum. We will announce this fact both here and on Twitter, once we have settled on a solution.

Unexpected error: Importing Files (*.md)

I was trying to import some markdown (.md) files from another folder, and the import fails with "filetype is unknown". I have a few hundred files to merge, and the idea of copy-pasting content is rather daunting.

I had tried just moving the .md files to the appropriate location within the Zettlr directory, but they were not indexed (keys, tags, etc.) when Zettlr was restarted.

Is there a way to force a re-index of content in the Zettlr folder?

Thank you in advance for any guidance.

--SDev

Comments

  • Text contents are always re-indexed on every restart, which is part of the reason why Zettlr is rather sluggish when starting with a lot of opened files. All files ending in either txt, tex, md, or markdown will be read, parsed, and indexed on every start of the program, and as soon as they are added.

    Importing Markdown files does not work because there is nothing to import, it's already in the correct format.

    Concerning indexing of tags and keys: Are you sure they're in the right format?

  • I guess I was premature in my concern. After importing all of the .md files into the directory structure and walking away from the computer for the evening, when I started looking this morning everything seems to be indexed and linkable just fine. My bulk import just took longer than I was expecting, but now I know I just simply need to wait a little longer.

    Thank you for your quick response as always.

    --SDev

  • Perfect! Glad it worked!

    Just for your info: I've begun work on the new file system, and I already implemented a caching mechanism which can speed up loading up to 90 percent after the data has been cached — so it will take some more time on the first read of a directory, in order to reduce the loading time a lot on each subsequent load!

Sign In or Register to comment.