We are currently planning to migrate to a different platform for the forum. We will announce this fact both here and on Twitter, once we have settled on a solution.

Beta 1.7 feeback

Have run the 1.7 Beta for a few days now (downloaded as soon as I got the release notification). So far, it is beautiful ... a lot of improvements and I am really happy! This is on Win 10 Edu (an academic version of Pro). I have set up a bit of custom CSS just fine. Apart from that, I have been testing in my normal workflow. I will try some of the things from Hendrick's list.

The only problem noted so far has to do with image insertion ... which I cannot make work as intended.

Suppose I have an image on the clipboard (but it could be a disk file ... doesn't matter). If I try to "paste" I get the nifty pop-up "Insert Image from Clipboard" dialogue. But nothing I do will convince that window to put the image into my document. I can rename or not rename the file. If I click "Save to current directory" the entire dialogue just vanishes, doing nothing. If I click "choose directory" ... the dialogue vanishes, doing nothing. If I hit "Return" (as it, mistakenly, says at the top of the dialogue), again, it vanishes, doing nothing. Obviously there is no "insert image" on a right-button mouse click (which I think there should be). Incoherently, if you select "Image" from the Text Format menu item (upper centre right) you do not get the "Insert image " dialogue at all, just the manual insertion template: .

That will let you insert a disk file as an image, but it's cumbersome. Why, after all, should I have to cut/paste in image into Typora in order to copy the link to Zettlr?! I mention that because it should - obviously, be a seamless operation. Typora is Electron as well.

I suspect it's not a big deal to fix it because the "Insert Image" dialogue is a really good idea and looks ready to go.

On the other hand, if I am just making some silly user error, I'd really appreciate knowing what it is.

Apart from the image insertion gremlin, the new beta is great!

Thanks!
ay

Comments

  • Suppose I have an image on the clipboard (but it could be a disk file ... doesn't matter). If I try to "paste" I get the nifty pop-up "Insert Image from Clipboard" dialogue. But nothing I do will convince that window to put the image into my document.

    This should've been fixed by the beta I released yesterday night. Was a just-in-time patch due to an issue that appeared on Sunday, I decided to fix that as well.

    Typora is Electron as well.

    nope, Typora is not an Electron app. Just look at the install file size, it's not even a tenth of what Zettlr buckles.

  • I love the new version, I haven't done all the user test list but I've been having this 2 bugs. I don't share screenshots, cause i feel they are not screenable. I'm working with Windows and the last beta update 1.7.2.

    Cursor jumping to the beginning of the note

    Description :

    When i'm writing my cursor just jumps back, for no reason, to the begin of the document. Example, let's say i'm going to type the sentence "my cat is hungry" in a document where the first line is "#thisismytitle". Now, i am in the middle of the document typing "my cat i"... I keep typing. I realize that what i'm typing is not showing in my screen anymore. I stop typing. Nothing happens for 1 sec maybe. Then i'm in the beginning of my doc. I see "hungr#thisismytitle".

    Frequency :

    This didn't happen to me with 1.6. It started happening with 1.7.1. It doesn't happen in other apps (tried typora and atom). It happens in any note : notes with 10 lines of content or full articles. Also in new notes : created with the 1.7 version and old ones. In the root file, in subfiles... One note open, many tabs open... The jumping back also happens when i'm not actively typing. It happens very frequently, at least 1 time every 25 minutes [1 time/pomodoro session]

    Tabs not closing

    Sometimes, i try to close a tab, the tab doesn't close. I get the X red animation. But nothing happens no matter how much I click. It has happen to me when i have more that 5 tabs opened. I haven't figured out how to reproduce it. Though when it happens i close Zettlr or press F5, and it seems to fix it. This has repeated itself at least 3 times since I got the 1.7

  • Concerning tabs not closing, please try out the 1.7 beta 4 which has been released yesterday. There were some reports, and I hope to having removed them now. Concerning the other point, I took the liberty of copying over your bug description to the official issue for this, because you provided A LOT of information which will help us pinpoint that really nasty issue! See here: https://github.com/Zettlr/Zettlr/issues/773

  • Thanks for constantly improving an outstanding application. This is really useful software. I'm trying out Beta 1.7.0-beta.5 on Windows 10 Pro.

    1. Export preferences dialogue menu file selection buttons do not work. When trying to change the Zotero citation database or CSL style, the little paper document icon to bring up a file selector does not work. It was possible to change the JSON file by cursoring to the end of the line and changing the name of the file.
    2. Expanded error reporting on problematic JSON library files not working. While Zettlr's citation functions work splendidly on a subset collection of my entire Zotero library, it does not work with an export file of my entire library. My full library probably no doubt contains a problematic citekey. I can't seem to track down the offending citekey. I was hoping the new error reporting would point to the troublesome citekeys, but I'm not seeing any errors reported in the log file.
      • I exported the full library and linked that JSON file to Zettlr (see dialogue issue above), and restarted Zettlr.
      • Upon restart there were no errors and the @ did not load a list of references as it had been doing with the subset JSON file.
      • Then I checked in the log file. Zettlr did not report any errors from the offending citekeys. The log file is as follows:

    [17:33:15] [Info] Cleaned up FSAL cache: Removed 241 remnants.
    [17:33:19] [Info] こんにちは! Booting Zettlr at Sun May 17 2020 17:33:19 GMT-0600 (Mountain Daylight Time).
    [17:33:19] [Info] Electron reports ready state. Instantiating main process...
    [17:33:20] [Info] Loaded all roots in 0.821 seconds
    [17:35:09] [Info] Cleaned up FSAL cache: Removed 241 remnants.
    [17:35:11] [Info] こんにちは! Booting Zettlr at Sun May 17 2020 17:35:11 GMT-0600 (Mountain Daylight Time).
    [17:35:11] [Info] Electron reports ready state. Instantiating main process...
    [17:35:13] [Info] Loaded all roots in 0.875 seconds

    I hope this helps. Thanks again for making something so incredibly useful! Love the tabs but the way...

  • Thanks for reporting, I'll have a look …

  • edited May 20

    On Linux, the new beta is a huge improvement. Specifically, having the native window titlebar/border makes it work so much more nicely. So far as I can tell there is no more flickering and it's easy to distinguish between other applications running behind it. Thank you.

  • Hello. I downloaded Zettlr 1.7 beta 6 for Windows 10, but when I opened the application there was only a large white window without menu, without icon, with which I could not interact. I uninstalled beta 6 and installed beta 5. All the menus are present in beta 5. So I can test beta 5 but I can't do anything with beta 6.

  • The beta 6 unfortunately was broken, but there's already a newer version that works!

  • I tried the 1.7 beta 7. The cursor problem hasn't been fixed. Right, or is it just me ?
    You said that OneDrive was a common element in the bug on the github's issue : https://github.com/Zettlr/Zettlr/issues/822. I use Mega for cloudstorage, not OneDrive, I still have the problem, Online or offline.

  • I am working with the last beta 1.7 beta 8. It is a file with 5,000 words, but the typing experience is quite slow. I do not have tables, or anything like images, but typing within the file itself, the typing does not match the pushing of the keys. I am on Mac Mojave, for what is worthy. I am wondering if the new Electron may create such an issue.

  • @Pharaoh I think it's an interplay of CodeMirror, Electron, and all the underlying logic (which is quite a bit) — if you'd like you can try deactivating all display plugins (e.g. "Render math", "Render tasks", "Render links" etc) — if that speeds up the editor considerably this means we have to get once again at optimizing these algorithms …

  • @hendrik I have disabled everything in the Display setting (Citations etc.), and the speed of typing is slightly improved. I said slightly. As you said, it might be a problem of algorithms. As you mentioned above about Typora, I am trying to type with IAWriter, and obviously it is faster, but it does not have Electron in its background.

  • Alright, thanks a lot for double-checking this! Maybe there are other things that run that are quite unstable; I'll need to run a performance analysis, because maybe this is also caused by the new bibliography refreshing algorithm, which may be fired way too often …

  • @hendrik I cannot export in beta 1.7 version 8. I have tried RTF, doc. and TeX. I get the following error: "Shell. open item is not an option." I also attach the relative screenshot. In my case, I cannot export at all.

  • @Pharaoh The just-released beta fixes that.

  • @hendrik I thank you for the new beta. I still have a problem for exporting in .rtf. I use NisusWriterPro for opening such a format, and now the export gives such elements, referring possibly to formatting transferred from Zettlr. I attach here. a very short example:

    {\pard \ql \f0 \sa180 \li0 \fi0 Local Stakeholder\u8217's participationat Ban Chiang World Heritage site\par}

    This part refers to the title. I do not include any other element, as it is a work in progress. I have tried to change the programme opening .rtf to Microsoft Word, but the same elements appear.

    So it seems that some cleanup from .md into .rtf needs to happen. Textedit in Mac is not useful for .rtf file, as most of the formatting is gone. And for Textedit anyway, only the title, not the main text was exported anyway, just for your information.

  • So it seems that some cleanup from .md into .rtf needs to happen.

    I heavily suspect there might be a problem with Pandoc, as this is reproducible by running Pandoc without Zettlr. Hence, it's out of Zettlr's responsibility.

  • @hendrik As the problem is in Pandect, what is the procedure to tell the Pancod people (aka John McFarlane), about it? Would you like to point it out to him, or should I raise the issue by myself? It is only a question of procedure. If you tell me how you ran your test outside Zettlr, I will try to reproduce it on my side.

  • @Pharaoh Yeah, it would be best to create a test markdown file with some contents, try to export it using Pandoc directly (e.g. pandoc -f markdown test.md -t rtf -o test.rtf) and see what it outputs, and then take that information directly to Pandoc on GitHub: https://github.com/jgm/pandoc/issues

  • @hendrik, about the Pandoc command, I have already contacted the Pandoc GitHub, and they told me that the option -s is missing. If I use -s (standalone option), the file is exporting correctly. Thus, I wonder if the option -s is missing in the Zettlr exporter to .rtf, and it determines the strange output.

    Also see: https://superuser.com/questions/200026/why-would-rtf-files-created-with-pandoc-be-opened-as-plain-text

  • Ah, that damned standalone flag! But added it, it works indeed! Sorry for sending you down the wrong path, the patch is done!

  • @hendrik no problem about it. Will the patch be in the next beta version next Friday?

  • Errrrr … I'm not sure when I'll drop the next beta, but yes, it'll be in there!

    Until then, as long as you don't export reveal.js files (I believe) you can simply modify the pandoc command in the advanced preferences tab, and add the standalone flag there! After the next beta, you can then "revert" the command back to default (as the standalone flag will then be set correctly)

Sign In or Register to comment.