We switched to a manual approval system for registration on this forum, as this makes it easier to keep bots out of the forum. We'll approve everybody who doesn't look like a bot!

Zettlr not giving the correct output

This must be something very simple, but I can't figure it out. For some reason Zettlr is not allowing pandoc to producing my PDFs as it should.

This is my simple md file:

And this is the output:

As you can see, the YAML has been completely ignored. However, if I run pandoc from the command line I get the following output:

Which is as it should be.

The Zettlr settings are still the default. So what am I missing?

Comments

  • The default Zettlr template does not create a titlepage by default, only projects. You have two options:

    1. Simply add \maketitle before the text of your file to make the LaTeX engine render a titlepage
    2. Create a custom template (which also could be the default template by Pandoc)
  • @hendrik said:
    The default Zettlr template does not create a titlepage by default, only projects. You have two options:

    1. Simply add \maketitle before the text of your file to make the LaTeX engine render a titlepage
    2. Create a custom template (which also could be the default template by Pandoc)

    Thank you hendrik!

Sign In or Register to comment.