We switched to a manual approval system for registration on this forum, as this makes it easier to keep bots out of the forum. We'll approve everybody who doesn't look like a bot!

LaTex issue

One suggestion and one question:

  • Suggestion: The documentation suggests that texlive-base is all you need on Ubuntu (19/04), but without texlive-full I am missing xelatex.
  • Question: How to solve this LaTex problem?
pandoc "/tmp/export.tmp" -f markdown --template="/tmp/template.latex" --pdf-engine=xelatex -o "/tmp/test.pdf"

kpathsea:make_tex: Invalid filename `Times New Roman', contains ' '
kpathsea:make_tex: Invalid filename `Times New Roman', contains ' '
Error producing PDF.
! Package fontspec Error: The font "Times New Roman" cannot be found.
For immediate help type H <return>.
 ...                                                                                         
l.67 \setsansfont

tks

Tagged:

Comments

  • Please feel free to add your suggestion to the docs and open up a pull request.
    Concerning your question: Obviously, the font "Times New Roman" is not installed on your computer. At least the font is not exactly called "Times New Roman". LaTeX is extremely sensitive to wrong font names.

  • TKs, I have proposed an update to the docs.
    Could the Linux installer have a default font that is found on all versions?

  • There's no pull request in the repository. However, I always thought Times New Roman is included everywhere?

  • @hendrik said:
    There's no pull request in the repository. However, I always thought Times New Roman is included everywhere?

    It doesn't seems so. At least on my system (fairly recent installed Manjaro Linux KDE) I got the same error.

    I found an old issue at Github about the same problem. Installing additional texlive-fonts did not help. Fix for me was the same as the last comment, replacing the fonts in the PDF preferences.

    I've looked quite long within Zettlr for the PDF preferences which were mentioned here - maybe they can be linked somewhere else in the GUI, e.g. under Preferences > Export?

  • I've looked quite long within Zettlr for the PDF preferences which were mentioned here - maybe they can be linked somewhere else in the GUI, e.g. under Preferences > Export?

    All preferences are under the Zettlr/File menu, listed:

    Preferences Screenshots

  • @hendrik said:
    All preferences are under the Zettlr/File menu, listed:

    I'm aware of that now. :smile:
    I just wanted to say I looked quite a while in the General Preferences Menu for the PDF settings and found none. (And I simply used the gear icon in the main GUI to get there, not the file menu.) But maybe it was just because I'm on linux without a global menu like macOS has it. So I was'n quite aware of all the menus (file, edit, view) regardless:
    Menu GUI under Manjaro KDE

  • yeah, I think to some extend I need to have another look at the UX to not become like this: https://userinyerface.com/ :smiley:

Sign In or Register to comment.