We are currently planning to migrate to a different platform for the forum. We will announce this fact both here and on Twitter, once we have settled on a solution.

Where is the vim input mode?

Hello,

I am new to Zettlr, so I apologize in advance if the answer is staring in my face: I wanted to try the vim mode but the only two available options in Preferences > Editor > Editor input mode are Normal and Emacs. Do I need to install something in order to have a vim mode? Is it no longer available?

In case some of it is relevant, this is the debug information from the Help menu:

General Information
Zettlr Version: 1.8.1

System: linux 5.9.13-arch1-1 (architecture: x64)

Build Dependencies
This build was compiled using

Node.js v12.16.3
Electron v10.1.5
Chrome v85.0.4183.121
v8 engine v8.5.210.26-electron.0
Zlib v1.2.11
OpenSSL v1.1.0
Current System Load
CPU Load: 1.5 %
Resident Set Size: 210.83 MB
C++ memory for JS Objects: 42.88 MB
Heap: 29 from 30.2 MB (Limit: 2121.73 MB)
Renderer flags
/opt/Zettlr/Zettlr
--type=renderer
--field-trial-handle=11816114060350298418,7788755254771678747,131072
--enable-features=WebComponentsV0Enabled
--disable-features=CookiesWithoutSameSiteMustBeSecure,SameSiteByDefaultCookies,SpareRendererForSitePerProcess
--lang=en-US
--app-path=/opt/Zettlr/resources/app.asar
--node-integration
--no-sandbox
--no-zygote
--background-color=#fff
--enable-spellcheck
--enable-websql
--disable-electron-site-instance-overrides
--num-raster-threads=4
--enable-main-frame-before-activation
--renderer-client-id=4
--no-v8-untrusted-code-mitigations
--shared-files=v8_snapshot_data:100

Tagged:

Comments

Sign In or Register to comment.