We are currently planning to migrate to a different platform for the forum. We will announce this fact both here and on Twitter, once we have settled on a solution.

Export fails "Unknown option --citeproc"

edited January 3 in General

I just tried to export a simple markdown file to several formats (txt, pdf, tex, html) and I get the same error message for all of them:

An error occurred on export: pandoc "/tmp/export.tmp" -f markdown -t FORMAT --citeproc --bibliography "" -s --pdf-engine=xelatex --mathjax -o "/tmp/file.md"

Unknown option: --citeproc.
Try pandoc --help for more information.

which pandoc gives me /home/fmoss/miniconda3/bin/pandoc. I set this as the pandoc path in the settings but nothing change, I still get the same error.

Citeproc is in /usr/bin/pandoc-citeproc.

Manual conversion via pandoc works flawlessly. I am on Ubuntu 20.4.

Also, changing the pandoc command in the settings to

pandoc "$infile$" -f markdown $outflag$ $tpl$ $toc$ $tocdepth$ $cslstyle$ $standalone$ --pdf-engine=xelatex --mathjax -o "$outfile$"

did work, but obviously now the citations are not exported correctly.

Comments

  • Unknown option: --citeproc. indicates that you have Pandoc <2.11 installed. Please make sure to install at least Pandoc 2.11.

Sign In or Register to comment.