We switched to a manual approval system for registration on this forum, as this makes it easier to keep bots out of the forum. We'll approve everybody who doesn't look like a bot!

Citation Database

Hello,

I've tried to add my zotero library to Zettlr. I followed all the steps written in the documentation. Everything goes well until step 3 : https://docs.zettlr.com/en/academic/citations/

When I write @, the autocomplete feature doesn't appear. If I write the quotation the same way is written in the documentation's example, it doesn't turn into another color. If I try with the citation key as shown in Zotero's information pannel header, nothing happens either. When I open the attachment sidebar, I see the "could not update bibliography".

This is the location and name of my exported betterJSON library.
C:\Users\ximem\Documents\Trabajos\Doctorat\DataBaseBook\BrouillonThese\TheseArtDesignDH.json
This is what I see in the GUI :

My Zettlr directory is "C:\Users\ximem\Documents\Trabajos\Doctorat\DataBaseBook\BrouillonThese"
I'm running the 1.5.0 Zettlr version, on Windows 10 Home.

My zotero version is 5.0.80

Thanks for the help.

Tagged:

Comments

  • The message "Could not update bibliography!" looks as if Zettlr has encountered an error while loading the database. When you start Zettlr, does it give you a notification for an error in the database? It should look exactly like the "You got the newest version of Zettlr"-message that appears everytime you start the app, in the up-right corner! The message should tell you where the engine stumbled.

    If there is no message, it might be in the logs. The logs are located in the data directory C:\Users\<your-user-name>\AppData\Roaming\Zettlr -> "Logs". Look out for everything labeled as an Error or a Warning!

  • I tried again changing the library file :
    1. I opened settings
    2. I changed the location of the JSON file
    3. I got this message : Changes to the library file detected… Reloading.

    1. If i go to log of today I found this
      Changes to the library file detected… Reloading.
    2. I waited for an error message for 5 mins, but nothing happened.
    3. I opened zotero (to check if there's anything appearing) but nothing
    4. I opened the attachment panel : "There are no citations in this document"
    5. I tried typing @B to get the autofill feature and nothing
    6. I opened the attachment panel again, it shows me "Could not update bibliography!"
    7. I opened the log file of today
      [12:34:03] [Error] undefined
      [12:34:03] [Error] Cannot read property 'replace' of undefined
      [12:37:15] [Error] undefined
      [12:37:15] [Error] Cannot read property 'replace' of undefined

    8. I restart Zettlr. No error message about the library, this are the new lines from the log file :
      [12:56:45] [Info] こうんいちわ! Booting Zettlr at Sun Jan 05 2020 12:56:45 GMT+0100 (Central European Standard Time).
      [12:56:45] [Info] Electron reports ready state. Instantiating main process...
      [12:56:45] [Warning] The translation string was malformed: Open Logs!
      [12:56:46] [Error] undefined
      [12:56:46] [Error] Cannot read property 'replace' of undefined
      [12:56:46] [Warning] The translation string was malformed: Open Logs

    Hope this explains something to you so I manage to fix it.

  • The "replace" keyword seems to point to something: On line 259 in the Citeproc-Provider, there are some brackets that are being replaced, with -- apparently -- a malformed citekey. This should not happen, because malformed keys get filtered prior to loading the ID-hints, so something is afoul there. I'll have a look later on!

  • Hi, I have the same issue - I type @a and nothing comes up despite a large number of references. Here is my entire log file:

    [09:25:14] [Info] こうんいちわ! Booting Zettlr at Tue Feb 11 2020 09:25:14 GMT+0800 (Hong Kong Standard Time).
    [09:25:14] [Info] Electron reports ready state. Instantiating main process...
    [09:25:15] [Error] undefined
    [09:25:15] [Error] Cannot read property 'replace' of undefined

    I'm using Zettlr 1.5.0, Zotero 5.0.8.2, Win 10 x64.

  • [09:25:15] [Error] undefined
    [09:25:15] [Error] Cannot read property 'replace' of undefined

    This does not sound great :S

    Erm, would you mind trying the latest 1.6 beta and see if the error still persists? Here: https://github.com/Zettlr/Zettlr/releases

  • Just tried it, got the same result unfortunately. FYI, as mentioned in the other thread, my library has over 10,000 Zotero items.

  • I am running 1.6.0-beta.4 under Win10 and experiencing issues similar to those reported in this thread. I've loaded the citation database and there's no response from @ and when a citation is added its not found among the attachments. The log file shows a similar error.

    [16:06:54] [Error] undefined
    [16:06:54] [Error] Cannot read property 'replace' of undefined
    [16:07:43] [Info] こんにちは! Booting Zettlr at Sun Feb 16 2020 16:07:42 GMT-0700 (Mountain Standard Time).
    [16:07:43] [Info] Electron reports ready state. Instantiating main process...
    [16:07:44] [Error] undefined
    [16:07:44] [Error] Cannot read property 'replace' of undefined
    [16:07:44] [Info] Loaded all roots in 1.334 seconds

    Thank you in advance for looking into this issue.

  • I tried unloading and re-loading the json file. I got no error messages but @ still doesn't bring up any Zotero items.

  • [16:07:44] [Error] Cannot read property 'replace' of undefined

    This error seems curious. Mh, may I ask anyone of you to simply send me your database? This way I can more quickly hack around in the codebase to find the error more quickly! Please feel free to send it to hendrik@zettlr.com, and I'll have a look at it!

  • My library is 8Mb, but I exported about 40 items into a small library and it was able to load in Zettlr, and the @ worked. I don't think I have the time to export different amounts of the library and repeatedly test, but if you want me to test particular characters that you suspect are causing the problem, I'm happy to work on that with you.

  • 8 MB? Oy, that's a lot. It might simply be that parsing the library takes an unusual amount of time (after all it has to be read in, parsed by citeproc, and then loaded into the renderer) ... mh, I think it might work best to have the library at hand, especially as Zettlr does not seem to produce any warnings. From what's written here, it could literally be anything

Sign In or Register to comment.