It will be disabled at any point in the future. Please post your discussions to any of these alternative available channels:

* GitHub Discussions:
* Zettlr Subreddit:
* Discord:

Issue with Zotero Citation

When I try to cite something in Zettlr from my Zotero library I can see the new citation in the dynamic dropdown list, but when I select the citation what is entered looks like a url:


I thought this workflow was working just a couple weeks ago, not sure what's changed. I export my library from Zotero as a CSL JSON, and I can see that Zettlr detects that the citation library has changed, and reloads the file. I can even see the new citation in the dropdown list, but the text is something I don't understand. The link leads to a "page does not exist" on the Zotero site.

If anyone has experienced this and has a solution I would greatly appreciate some guidance.

Macbook Pro 2019,
Big Sur 11.2.3
Zettlr 1.8.7
Zotero 5.0.93




  • Do you have some screenshots for us?

  • It looks as if something in your Zotero database uses the item links as citekeys, and that breaks the preview function o.O

    Would you mind opening your CSL-library in TextEdit and giving me a screenshot of that?

  • Hey, sorry for the slow response - here's a screenshot of the library - looks like the "id" is being used as the preview.

  • Ah it looks you're not using BetterBibTex to generate citekeys with. Then the ids would have the format AuthorYear (or whatever you choose)

  • Could this have something to do with:

    Zotero>preferences>Export>default format ? Try Better Bibtex @citekeys Quick Copy?

    or even:

    Zotero>preferences>Better Bibtex>Quick copy format? I know it probably shouldn't relate but there is an option to copy as a zotero select link. Try Pandoc citation instead?

    Are you running Zotero Beta? I have some strange behaviour from time to time with the automatic export.

  • No, I'm not running Zotero beta, precisely because I don't want any unexpected behaviour for now …

  • Reinstalling Better Bibtex seemed to fix the problem. Thank you for your help.

Sign In or Register to comment.