We are currently planning to migrate to a different platform for the forum. We will announce this fact both here and on Twitter, once we have settled on a solution.

automatic citations don't work

This used to work, but recently when I type @ and begin typing the names of authors (that I know are in my zotero library) I don't get anything. There is no drop down list that appears.
My zotero library is up to date and the settings are pointed to the right place.
Anyone else have this problem?


  • It might be due to unallowed characters in citation keys. Citr, the library Zettlr uses for managing citations, is very strict about that and aborts if it encounters wrong citations. The issue is known and we're working on a way to notify users of that instead of simply failing.

  • Does this mean that it fails if there are ANY "wrong" citations in the entire library or just with the particular citation I might be searching for?
    I want to note that when I type [@ or @ that nothing appears to be happening/no library is being called up/activated.

  • I have the same problem.

  • Does this mean that it fails if there are ANY "wrong" citations in the entire library or just with the particular citation I might be searching for?

    Currently as soon as one disallowed char is encountered, Zettlr will abort loading the library file. As mentioned, this is not desirable, and we're on it, albeit this might still take some weeks to remedy :/

  • OK, thanks for the info! I'll hold tight!

  • I already announced it on Twitter, but for completeness also here: I've just updated the source for the Citr library to allow for diacritics and even non-latin scripts to be allowed within citations, so from the next release onward, Zettlr shouldn't spit out that many errors anymore :)

  • Hi Hendrik, just out of curiosity. Is the new version of Zettlr 1.4.3 addressing the issue? I have not seen it mentioned in the Changelog. And my .bib file continue to say that it cannot update the bibliography. I know they are unicode character spread, and possible some Thai language characters as well.,,

  • Hey, it's not in the Changelog because it's in the external library; so you can find it here: https://github.com/Zettlr/Citr/blob/master/CHANGELOG.md

    But yes, it's bundled with 1.4.3; so I am not quite sure why your library still says it can't use your file. But an error is thrown if the BibTex-file can't be converted to CSL by Astrocite, maybe some other fields are causing a hiccup…?

  • Hi Hendrik,
    I thank you for the email. I believe that you are right, as you say about other fields may cause an hiccup. As I have more then 4,800 references, and they are going to be exported to bibtex almost daily, I need to find the culprit. Do you have any idea of how such field can be identified? I tried with JabReb before, and it finds fields that the first letter is not capitalised and so forth. I believe that it is not the major issue. I understand that for Citr not having the bibtex ID is a major problem, as it gives the error. But I cannot find a way to identify the problem, unless I go batch by batch with the import, and try to narrow the issue to a certain group.

    Any suggestion?

  • Mh, the amount of 4,800 references seems a bit high. I would first suggest to reducing the amount, because remember that all of these references will be stored internally in multiple places (main process + renderer), which means that, depending of the amount of fields within these entries, this could use a significant part of your RAM. Do you really need all 4,800 references to cite?

    Then, this amount of references might also be one of the reasons, because after certain sizes of objects in memory, even a Node server will capitulate and not work anymore. So as a first suggestion and, maybe, as some part of "data reduction", would it be possible for you to only export a partial library which you can then keep updated with the works you actually need to cite? This might even be the solution to your problem!

  • Hendrik,At the end I have found the culprit. There was a citation ID as such: D'Andrea2015. The apostrophe in the surname was blocking citr to refresh. Now, I am able to see all my references, but as you said, to look through all of them is quite slow. As I use a bibliographic software manager, I discovered that it got the same function of Zotero, with a citation windows, so I can select the references through Bookends and paste them in Zettlr. In this way, the entire process is faster.

    You said about to reduce the database. I work mostly in Egyptology and Cultural Heritage Management, and the references are pasted into one database only. Many of the references go back to my PhD completed in 2004, and with all the researches after that. As I write papers with very long list of references, it becomes difficult for me to split the references in smaller chunks. But I believe that when I hit 10,000 references, I may think about such approach.

    Thanks again.

  • Ah, yes, apostrophes can be ugly within citation IDs. But I'm glad it worked out for you!

    Concerning the amount of references: I fully understand that this is not the best answer one might hope for, but I'm always a little bit concerned as to the amount of data being read into the app. Because all references are held twice in the RAM (first in the main process, where the heavy lifting is being performed, and then in the renderer process for the dropdown list), and I always fear that JavaScript uses a lot of memory just to keep the objects. But I might be wrong, I have never really dealt with memory consumption in JavaScript, so maybe it's just a few megabytes which modern computers with 8+ gigs of RAM should easily be able to deal with :) After all, if your library file works, it's a good indicator that this indeed holds true and we can rest assured that even 10,000+ references work fine!

  • edited November 2019

    Hi there,
    I updated Zettlr but am still having the same problem as before. Nothing happens when I try to call up/insert citations using [@]
    Any thoughts?
    [In other news, when I add words to the dictionary the squiqqly red lines don't disappear.]

  • Just to clarify. When I export to Word, there is no problem/error in generating the references. I just can't access/select references from my Zotero library in Zettlr as before.

  • Mh ... would you mind sending me your library? I've heard about these problems from different people now, but never found a definitive answer as to what is going wrong!

    And concerning the "Add to dictionary": CodeMirror is a little bit too optimised, so to make the red lines disappear, you simply have to continue typing in that very line. This will prompt CodeMirror to re-evaluate the line and realise that the word you just added to the dictionary is actually now a correct one!

  • @hendrik will do!

    And thanks for the tip about the Add to Dictionary feature. That works for me.

  • Perfect! I just sent you a message concerning the library files!

Sign In or Register to comment.